When running G-RSM on TeraGrid machine at SDSC (IA-64 Liux Cluster), use the latest compilers.
  • Log in to tg-login.sdsc.teragrid.org
  • Add these two lines in your .chsrc. They will replcae default ifort and mpif90 with new compilers.
    • soft add +mpich-gm-1.2.6..14b-intel-r2
    • soft add +intel-c-9.1.038-f-9.1.032
    • This is the current @teragrid-dev version but produces an error on sigphys.F: soft add +intel-c-8.1.035-f-8.1.031
    • If you use older compilers (currently default), you need to recompile *exp*.F subroutines with optimization level 0 (-O0 rathern than -O3).
  • For more information about software:
  • TeraGrid SDSC Links